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Introduction 

The Armadillo Analyzer is the software tool used to obtain and analyze data recorded by 

an Armadillo Above Ground Marker (or AGM). 

The Analyzer can perform the following functions: 

1. Set up Armadillo AGMs before a job 

2. Synchronize a computer’s time with the GPS time from an Armadillo AGM 

3. Download data files from the Armadillo AGMs 

4. Analyze Magnetic, 22 Hz, and Geophone data to accurately determine pig 

passage times 

5. Export user-defined data from a list of supported fields to a user-defined format 

for correlation with Inline Inspection (ILI) tool logs 

6. Delete files on the Armadillo AGMs 

7. Batch firmware & boot loader updates to the Armadillo AGMs 

 

This User’s Guide describes the features of this program. 
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Changes From Prior Versions 

This section details the changes between previously released versions. 

Date Installer 

Version 

Application 

Version 

Changes 

 2.1.5 2.1.4804.18564 - Can zip up filtered passes for easy storage and/or distribution. 

 2.1.0 2.1.4682.21468 - CRITICAL BUG FIX: UTC timestamped data may be off in the early portions of 

older files. This may affect pass times if the GPS sync hadn’t been received by the 

AGM yet. This has been corrected and will auto-correct old files opened with the 

Analyzer. 

- Repository concept has been removed from the Analyzer. You now just “Open 

Files” 

- Downloaded filenames now specify job name, agm name, and correct time 

information. 

- Files of size 0 will no longer be downloaded from AGM. 

 2.0.10 2.0.4580.18952 - Can set triggering on individual 22 Hz channels 

- Uploads data to ‘Analyzed Runs’ section of www.armadillotracks.com 

- Fixed bug when downloading by time (selection of data was off by 15 seconds) 

- User may now choose how often updates are checked 

02/25/15   - Updated graphics to new logo, new company name (PureHM Inc.) 
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Installing and Updating 

Installing 

The latest copy of the Armadillo Analyzer can be found on the internet at the following 

location: http://www.armadillotracks.com/Analyzer/ 

You will need to download this file and unzip it. Run the Armadillo Analyzer v2 

Install.msi file and follow the instructions to install the application. 

By default, this will install the Analyzer to the following directory for 32-bit operation 

systems (Windows XP 32-bit, Windows Vista 32-bit, and Windows 7 32-bit): 

C:\Program Files\PureHM Inc\Armadillo Analyzer\ 

The Analyzer will be installed to the following directory for 64-bit operation systems 

(Windows XP 64-bit, Windows Vista 64-bit, and Windows 7 64-bit): 

C:\Program Files (x86)\PureHM Inc\Armadillo Analyzer\ 

The Armadillo Analyzer installer also creates the following directories: 

• AGMs – when Bluetooth® is used to successfully connect to an AGM, the 

connection information will be stored in this directory for future connections. 

• Themes – any themes that you modify or create are stored here. Please refer to the 

section Other Features > Theming for further details. This folder is usually 

created in your My Documents folder (Documents\Armadillo\Themes\) 

so other Armadillo applications can reuse the themes. 

• Templates – any export templates that you modify or create are stored here. 

Please refer to section Exporting Data > Export Templates for further details. This 

folder is created in your My Documents folder 

(Documents\Armadillo\Templates\). 

 

Updating Your Version 

Version 2 of the Armadillo Suite of programs will perform a version check against the 

Armadillo web service every time it is launched if your computer has an internet 

connection. You will be informed of any new version. You will be informed if the update 

is critical or not.  

Updates to the Armadillo Analyzer are as simple as downloading the latest version of the 

Analyzer from the Armadillo Tracks web page and installing it on your system. Your 

AGMs, Themes, and Templates will not be modified and will persist between the old 

version and the new version so any customization that has been performed will be kept. 
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GPS vs. UTC Time 

When the Analyzer is first run, you will be prompted to choose between UTC or GPS 

time.  

This is a very important choice, and it will affect all software operation. It is vital that 

you confirm with your company which time standard is used end-to-end with your jobs. 

An erroneous choice may cause an incorrect correlation to dig locations. 

UTC 

This is the most common form of time used in the industry. It represents time in 

'human-readable' terms - the same you would see on most clocks and watches. 

This time can actually shift up to twice a year due to the Earth's rotation slowing 

down or speeding up, although this is a rare change. 

GPS 

GPS time is guaranteed to be the most accurate and never adjusts forward or 

backward - it constant keeps ticking forward. It does not match what most GPS 

units display as time, but is the absolute most reliable format of time to use. The 

current offset from UTC time (at least until July 1, 2013) is 16 seconds. 

 

If you make an incorrect choice and need to change this setting after the application has 

already run, you can open the Options dialog and change the time standard. A warning 

will display indicating the seriousness of this change. 

 

 
Figure 1 - Choose UTC vs. GPS 
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Overview 

The Armadillo Analyzer consists of two main panels: 

1. Detailed Info Pane 

2. Pass Selection and Graphic Analysis 

 

1. Detailed Info Panel 

The detailed info pane is shown on the right-hand side. It can be collapsed by clicking on 

the bar on the right-hand side of the screen, or by hitting ctrl-I on the keyboard. 

 

Figure 2 - Pass Selection & Graphic Analysis 

2. Pass Selection & Graphic Analysis 

In Figure 2 - Pass Selection & Graphic Analysis, we see the detailed info pane is still 

open on the right-hand side of the window. It can still be collapsed by clicking on the 

right-hand side bar or by hitting ctrl-I, and more screen real estate will be given to the 

graphs shown. 

The remaining pane, on the left, is the workhorse of the Armadillo Analyzer application. 

This is probably where most of your time will be spent. Here you select the pass that you 

would like to analyze from the list on the left, and the pass’ information is displayed in 

the graphs and in the detailed info pane on the right. 

This pane is discussed in much more detail in the Analysis section. 
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Connection to Armadillo AGMs 

A core feature of the Armadillo Analyzer is the ability to connect to multiple AGMs at 

the same time to perform the same function in parallel. The Analyzer connects to one or 

more AGMs in the same manner for all functions relating to the boxes. This section of 

the guide walks through how this is performed. 

Any function that supports connection to the AGMs will open up with the following 

screen: 

 

Figure 3 - Communication Selection 

If Bluetooth® is not available, or an unsupported Bluetooth® Stack is installed, then the 

Analyzer will not allow this selection and will force you to select a “USB / Paired 

Bluetooth®” connection. 

Bluetooth® 

If Bluetooth® is selected, the device will search the surrounding area for any Bluetooth® 

device with a serial connection capability, including devices that are not Armadillo 

AGMs. By default only AGMs that start with a chosen prefix will be shown. The default 

prefix is “AGM-”, but this can be changed. 

It is highly recommended that you use Class 1 Bluetooth® to connect to the 

AGMs. This has a much larger range (up to 300 feet) and will work the best with 

the AGMs. Class 2 devices can be used to connect to the AGMs, but Bluetooth® 

may not work consistently. 

USB / Paired Bluetooth® 

If “USB / Paired Bluetooth®” is selected, the Analyzer can search every communication 

serial port that is attached to the computer and attempt to find any connected Armadillo 

AGM. This detection will automatically detect any valid devices. 

If you have manually “paired” with Bluetooth® to one or more Armadillo AGMs 

to a COM Port, this option is the one you would choose. 

Once you have selected the mode of communication, the Analyzer will begin its search 

automatically with Bluetooth, or when you click the  button: 
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Figure 4 - AGM Selection 

In order to speed up connection to our devices by Bluetooth®, once you have 

successfully connected to an AGM, it will be cached and shown on this screen by default. 

No automatic search will be performed. If you would like to add more devices that you 

haven’t successfully connected to, you can click the  button to scan the area once 

again. 

When you have selected at least one AGM, you may click  to perform the operation 

you have chosen. 

To select multiple AGMs in this window, you can hold down the ctrl key and select or 

deselect individual boxes. The checkbox  will not be checked when 

you first see this window, and will default to the prefix “AGM-”. When this checkbox is 

checked, only those devices that begin with the specified prefix will be displayed in the 

list. If you uncheck this option, the list will show all the devices detected by your 

computer. 

If you’d like to do a search again for any device (one that was either just turned on or 

connected the computer), clicking  will perform the search again. 

In some cases, the name of the AGM does not come through quickly enough for 

the AGM to show up in this list. Clicking  will usually reveal it the second 

time. 
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Downloading Files 

Once a pigging run is complete, the data needs to be downloaded from the Armadillo 

AGMs to your computer to be analyzed. You will be prompted to select the location of 

the downloaded files. 

Download Steps 

1. Select Manage AGMs > Download… from the main menu, or hit ctrl-D as a 

shortcut. 

2. Select the Armadillo AGMs that you wish to download any data from. Please 

refer to Connection to Armadillo  for the instructions on how to do this. 

3. Once you have chosen the boxes you wish to connect to, click . You will see 

a screen that will soon populate with an aggregate collection of the jobs that are 

present on the boxes that you’ve connected to: 

 

Figure 5 - Available Downloads 

This screen aggregates all of the job information that is available on all of the 

boxes and presents your choices in one single list, allowing for easy selection of 

jobs.  

You will only be able to download one job at a time. Make your selection here 

and click .  

4. The next screen will prompt you to choose a folder where the data will be 

downloaded. This folder location defaults to the last folder the Analyzer opened 

data from, or the last download location (whichever happened last). 

 

Figure 6 – Download Location 

If the folder does not exist, it will be created when your download starts. 
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5. The next screen allows you to pick how you will choose your data to download. 

 

Figure 7 - Download Method 

You can choose to download by specifying a list of times, or by using the times 

that the AGM indicated was a trigger. You may also choose to download all the 

data. 

i. By Time 

If you choose to download by time, you will need to enter a list of 

times, preferably from a tracking sheet. The screen shown in 

Figure 8 is very flexible and will accept multiple time formats.  

 

Figure 8 - Download by Time 

Simply copy and paste the times from the tracking sheet into the 

text box on the left and click . If the software cannot figure 

out what time you intended, it will not add the time and will inform 

you, allowing you to correct the format. 

You have many options on this screen. The first is the time offset. 

When the job is setup, the operator can specify the time offset of 

the job (see the section “Set Up AGMs”, below). This value can be 

overridden here, but it should not need to be. 

The option at the bottom ( ) specifies 

the range of data to download before and after the specified times. 
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The default is 30 seconds, but if you’re having trouble narrowing 

in on a pass, you may want to increase this value. 

Once you have your times entered, click . A summary of the 

times you’ve specified will be displayed. 

 

Figure 9 – Download by Time Summary 

Each time will be listed, along with the number of data files that 

will be downloaded and from which AGMs they will be 

downloaded from. If the specified time is not found on any of the 

connected AGMs, the row will be highlighted. 

ii. By Trigger 

If you choose to download by trigger, you will be presented with a 

list of triggers from the box. Each trigger will show the time of 

trigger as well as what sensor triggered: Magnetics (MFL) or 

22Hz. 

 

Figure 10 - Download by Trigger 

Select the passes you would like to download and click . You 

will then be asked how much data to download on either side of 

the specified trigger time. The software initially defaults to 6 

seconds before and 3 seconds after. You can customize this as you 

see fit. 
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Figure 11 - Download by Trigger Padding 

iii. All Data 

If you choose to download all of the data on the box, you will be 

presented with a list of all the recorded data on the box for the 

selected job. Each data file will show the range of time recorded.  

 

Figure 12 - Download All Data 

Select the data files you would like to download and click .  

 

Downloading all of the data is a very time-consuming process 

when compared to downloading by time or by trigger. It can take 

up to 10 times longer to transfer the data, in addition to the extra 

processing time for loading and analyzing the data. It is 

recommended you only download full data files when absolutely 

necessary. 

 

Each data file will be downloaded in 10-minute increments of data 

with an overlap of 30 seconds. This increases the number of files 

created on your local computer, but ensures that they will load 

quickly and correctly within the Armadillo Analyzer program. 

 

If you download all of the data, it is recommended that you use the 

Crop Data To Shown feature to remove extraneous data when 

analyzing for a pass time. See the Graphic Analysis section, below. 
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6. The final screen shows the progress of each pass in the download. Each AGM 

will be downloaded in parallel, greatly speeding up data retrieval.  

 

Figure 13 - Download Progress 

Each AGM will show the current progress for downloading from that AGM.  

If you’d like to view a detailed report of the progress, click on the  button. 

This will show a list of items for that particular AGM. You may right-click 

this list to save the messages – this is useful when investigating or reporting 

problems (see the Technical Support section). 

If time was selected in the aggregation that is not available on an AGM, that data 

retrieval is skipped for the AGM. 

7. Once downloading has completed, the  button will appear. Click it and the 

download screen will close. 

The downloaded files will not be automatically opened upon download. If 

you wish to view them you will need to explicitly open the files with File 

> Open command. 

Opening Downloaded Files 

Once files have been downloaded, you will want to open them with the Analyzer to view 

the data, find passes, and select pass times. Choose File > Open from the main menu, 

and select either the one file, or a range of files to open and analyze. 

 

Figure 14 – Data File Selection 
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Armadillo Pass Files (with the extension .apf) contain the data downloaded from the 

AGM. 

An .apf file is merely the data recorded by an AGM over a specified time 

period. There is no guarantee there is an actual pass within the data. 

There are two ways to select multiple data files: 

1) Click the first file of a range you would like to select. Then hold the shift key 

and select the last file. All the files in the middle will be chosen. 

2) Hold the Ctrl key, and select each file to open individually. 
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Deleting Files 

The Armadillo Analyzer does not automatically delete files from the AGMs. This is to 

allow you to verify that the data was downloaded properly and to ensure that data 

integrity is maintained. 

Once you have analyzed your data and are satisfied that all the information you needed 

has been retrieved, you may then connect to the boxes to delete the files on the AGMs. 

File Deletion Steps 

1. Select Manage AGMs > Delete Files… from the main menu. 

2. Select the Armadillo AGMs that you wish to delete data from. Please refer to 

Connection to Armadillo  for the instructions on how to do this. 

3. Once you have chosen the boxes you wish to connect to, click . You will see 

a screen that will populate with the jobs that are present on your selected boxes. 

 

Figure 15 – Choose Folders To Delete 

This screen aggregates all of the job and site folders that are available on all of the 

boxes and presents your choices in one folder tree.  

You cannot delete any data from the current job folder, as the AGM is 

constantly using that folder for logging and writing data. If you’d like to 

delete the current job folder, you will need to change the current job of the 

AGM, power cycle it, and then you may delete the prior job folder. 

4. Deletion of files cannot be undone. The next screen warns you, and asks you 

to confirm that you would like to delete the selected files. 

5. The final screen shows the progress of each deletion. Each AGM will be deleted 

in parallel, greatly speeding up the process.  
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Figure 16 - Deletion Progress 

Each AGM will show the current file deletion progress.  

For jobs or sites that had a lot of data, the deletion step could take many 

seconds, as there is a lot of data to delete. This is normal. 

If you’d like to view a detailed report of the progress, click on the  button. 

This will show a list of items for that particular AGM. You may right-click 

this list to save the messages – this is useful when investigating reporting 

problems (see the Technical Support section). 

If a folder was selected in the aggregation that is not present on an AGM, that 

item is skipped for deletion from that AGM. 

6. Once the deletions have fully completed, the  button will appear. Click it 

and the deletion screen will close. 
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Set Up AGMs 

Before every job, each AGM should be set up with the parameters for that job. 

Setup Steps 

1. Select Manage AGMs > Setup… from the main menu. 

2. Select the Armadillo AGMs that you wish to set up at this time. Please refer to 

Connection to Armadillo for the instructions on how to do this. 

3. Once you have chosen the boxes you wish to connect to, click .  

Each screen in this wizard will set up a different aspect of the job the AGM will 

be deployed to. The first screen specifies the job name: 

 

Figure 17 – Setup Screen – Job Name 

The job name cannot exceed 31 characters, and is restricted to valid folder-name 

characters. The following characters are not allowed:  

/ \ ? : * “ < > | ; ^ & % @ ! ( ) [ ] { } $ # = 

It is recommended that you precede the job name with the year, month, and 

day to keep track of your jobs by date in your file system, but this is not 

required. 

4. The next screen specifies which sensors will cause the AGM to automatically 

trigger. 
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Figure 18 – Setup Screen – Triggers 

At this time, the AGM will always trigger on the magnetics channel, and this 

cannot be turned off. You have the option of turning off the 22-Hz trigger to avoid 

false triggers on runs that do not have a 22-Hz transmitter. 

Even though you can turn off what triggers the box, the AGM is always 

recording data from all the sensors. 

5. The next screen specifies the hourly offset of the job. 

 

Figure 19 – Setup Screen – Time Offset 

All the data on the AGM is recorded at Greenwich Mean Time (GMT). This 

offset specifies the ‘real world’ time that the job is being run at so the software 

can display the data at the expected, tracker-recorded time. This offset can also be 

adjusted after the fact. 

6. The final screen shows the progress of each AGM to be set up. Each AGM will be 

set up in parallel, greatly speeding up setup.  
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Figure 20 – Setup Progress 

Each AGM will show the current setup progress.  

If you’d like to view a detailed report of the progress, click on the  button. 

This will show a list of items for that particular AGM. You may right-click 

this list to save the messages – this is useful when investigating reporting 

problems (see the Technical Support section). 

7. Once each AGM has been set up, the  button will appear. Click it and the 

setup screen will close. 

The information that has been changed on the AGMs will not take effect 

until the AGMs have been power-cycled. 
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Hibernate AGMs 

To extend the operational battery life of the AGMs, you can set a Hibernation time. The 

AGM will stay off until a time you specify for them to ‘wake up’. When they wake up, it 

will be just as if you pressed the button to start them. 

This feature allows for the predeployment of AGMs on the job for days or even weeks 

without consuming the life of the battery until the AGM is needed. 

Hibernate Steps 

1. Select Manage AGMs > Hibernate AGMs… from the main menu. 

2. Select the Armadillo AGMs that you wish to Hibernate at this time. Please refer 

to Connection to Armadillo for the instructions on how to do this. 

3. Once you have chosen the boxes you wish to connect to, click .  

You will be presented with the screen to specify the time for the AGMs to wake 

up: 

 

Figure 21 – Set Hibernation Time 

The Time Offset at the top of the screen is for translation of your local time into 

the time the AGM understands – GMT Time. Changing this value only changes 

the displayed time at the bottom of the screen. It does not change the time offset 

of the AGM itself. 

The second section, Enter Time To Wake Up, allows you to either Clear the Wake 

Up Alarm, or specify a time that the AGMs will Wake Up. If you choose to clear 

the wake up alarm, then the AGMs will not wake up if they are shut off. 

If you choose to set a Wake Up time, you can specify how many days, hours, and 

minutes into the future. The displayed wake up time will adjust to estimate when 

the AGMs will power on. 

4. The final screen shows the progress of each AGM to be set up. Each AGM will 

have its wake up alarm set in parallel, greatly speeding up setup.  
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If you’d like to view a detailed report of the progress, click on the  button. 

This will show a list of items for that particular AGM. You may right-click 

this list to save the messages – this is useful when investigating reporting 

problems (see the Technical Support section). 

5. Once each AGM has been set up, the  button will appear. Click it and the 

Hibernate AGMs wizard will close. 

Tip: If you set the hibernation using Bluetooth, the AGMs will 

automatically shut off when the wizard is closed. 
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Get Information 

The Armadillo Analyzer can connect to one or more AGMs to retrieve the current setup 

and state information for those boxes. This is useful both as a diagnostic tool and for a 

quick check to ensure everything is set up correctly. 

Get Information Steps 

1. Select Manage AGMs > Get Information… from the main menu. 

2. Select the Armadillo AGMs that you wish to see information about. Please refer 

to the Connection to Armadillo section for the instructions on how to do this. 

3. Once you have chosen the boxes you wish to connect to, click . The 

software will connect to each box and display a window that has a tab for each 

connected AGM. 

 

Figure 22 – Get Information 

Each node can be expanded to provide more detailed information. For example, in 

Figure 22, above, the Job node is expanded to show the current job-related 

settings on the AGM. 
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Synchronize Computer Clock To AGM Time 

The Armadillo Analyzer can connect to one AGM and adjust the local computer’s clock 

to match the time reported by the AGM. You would do this to synchronize a pigging tool 

to the AGM, using the computer as an intermediary. 

The software will use either the UTC or GPS time, depending on your selected Time 

Standard. Please see GPS vs. UTC Time, above, for more information on this. 

Due to the varying speeds of wireless connections, it is recommended you perform 

this operation with a USB cable connection to ensure the most accurate 

synchronized time. 

Synchronization Steps 

4. Select Manage AGMs > Synchronize Time from AGM… from the Manage AGMs 

menu. 

5. Select the Armadillo AGM that you wish to get the time from. For this function, 

you will only be allowed to choose one box to connect to. 

6. Once you have chosen the box you wish to connect to, click . The final 

screen shows the progress of retrieving the AGMs time.  

 

The first step is to Ping the box to determine the length of time it takes for a 

message to reach the box and return. The AGM’s current time is then retrieved, 

along with the length of time since the last GPS fix was obtained. 

 

Figure 23 – Synchronization Confirmation 

You will be prompted with the time since the last GPS fix, and can decide if you 

wish to synchronize the local computer’s time against that AGM. In this example, 

the time since the last GPS fix is only 1 minute and 5 seconds. You would 

probably click . It is generally recommended that you only synchronize with 

AGMs that have gotten a valid fix within the last 2 hours. 

If you choose to click , the local computer’s time will be updated to be in 

sync with the AGM.  
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If you’d like to view a detailed report of the progress, click on the  button. 

This will show a list of items for that particular AGM. You may right-click 

this list to save the messages – this is useful when investigating reporting 

problems (see the Technical Support section). 

7. Once the time has been retrieved and the computer’s time has been synchronized, 

the  button will appear. Click it and the synchronization screen will close. 

In order to perform this operation, you must have sufficient permissions to 

change your computer’s time. If you do not, please speak with your system 

administrator. 

 

PLEASE VERIFY THE TIME CHANGE BEFORE & AFTER TO 

ENSURE YOUR COMPUTER CLOCK HAS BEEN UPDATED 

 

The time on your computer is updated to the UTC time from the AGM. 
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Analysis 

The main purpose of the Armadillo Analyzer is to review data from the AGMs and select 

valid pass times from that data. This section describes this in more detail.  

Choose Which Files To Analyze 

Please open the files you wish to analyze. See the section “Opening Downloaded Files” 

for more information. 

Once you have selected your data files and opened them, they will be available for 

selection in the File Selection list in the Analysis pane. The first file will be automatically 

selected and it’s detailed information shown. 

 

Initially, only Pass Files that are marked as Valid will be visible 

due to an automatic filter that is applied (see below). All passes are 

initially Valid by default. 

 

File Selection, Filtering, Viewing, & Sorting 

In the Analysis pane, there will be a list of files that are available for Analysis.  

 

Figure 24 - File Selection 

Modified Files 

When you have modified a Pass File, either by selecting a pass time, modifying 

the time offset, changing the Job or Site name, etc., the changes will not be 

persisted until the data is saved.  

Any modified Pass File will be italicized in the Pass Files list to indicate it has 

unsaved changes. If you try to close the Analyzer without saving, you will be 

warned that you are about to lose your changes. 

You can save your changes by hitting Ctrl-S or by selecting File > Save from the 

main menu. 
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Filtering 

When the Analysis pane is initially populated, it is filtered to the list of Valid 

Pass Files available. If you’d like to remove or change this filter, right-click on 

the list as seen in Figure 26, or click on the highlighted Filter Bar, as seen in 

Figure 25. 

 

Figure 25 – Filter Bar 

 

Figure 26 - Changing the Filter by Right-Click Menu 

The Filter Bar will open a Filter Window that will stay open while you are 

analyzing your pass file data. You can use this Filter Window to modify the 

filters, and the Pass File list will adjust as you select or deselect filters. 

 

Figure 27 – Filter Window 

You can clear all filters, or choose to filter by many criteria. 

You can see what filter is currently applied by hovering your mouse over the 

Filter Bar above the File Selection list. 

Multiple filters can be applied. As an example, if you’d like to view the data from 

only two jobs from the five in the repository: 

1. Open the Repository pane and open the Entire Repository node. 
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2. Open the Filter Window and expand the Job filter (see Figure 27, above).  

3. Select the first job you’d like to include. The Pass File list will update in 

the Analysis Pane. 

4. Select the second job you’d like to include. The Pass File list will update 

in the Analysis Pane. 

Filters are a powerful tool that can greatly speed up your data analysis. It is highly 

encouraged that you experiment with them. 

 

File Selection 

You can choose which file you would like to examine by selecting it in the Pass 

File list. The graphs containing the data from that file will automatically update, 

and the Detailed Information from that file will update on the right-hand side. 

If you need to quickly mark many files INVALID or VALID, you can do so 

by clearing the Filter so all the files are shown in the list. Then, select the 

first file in the list, and use the right arrow to mark the file as INVALID or 

the left arrow key mark the file as VALID.  

File Viewing 

By default, pass files in the Pass File list are shown by date and then by 

length of data that is recorded. You have the option of changing the view to 

by Site. 

 

Figure 28 – Change File View 

File Sorting 

By default, pass files in the Pass File list are sorted by date of recording. You 

have the option of changing the sort to sort by Site as well. 

 

Figure 29 – Change File Sort 

Graphic Analysis 

Once you have found a file to edit, the data from that file is viewed in graphic format in 

the Analysis pane. The types of data you can view include: 

1. Magnetics (MFL in the X-plane, Y-plane, and Z-plane) 
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2. 22 Hz Antenna (Internal Horizontal, Internal Vertical, and External if 

available) 

3. Geophone (Internal, and External if available) 

 

Hovering over a currently-active toggle button will highlight that 

data line on the graph, and bring it to the front of the data. This is a 

very useful feature. It is recommended you use this. 

 

The view consists of three graphs, one for each type of data. Each can be collapsed to 

make more room for the other graphs by clicking on the header bar for each type. 

 

 
Figure 30 – Three Graphs 

You can zoom in on the graphs by left-clicking on any one and dragging the mouse. 

When you let go, the graph will zoom into the region outlined.  

 

If at any time you would like to ‘reset’ the view of the graph, right-click and select 

“Restore to 100%”. This will snap the graphs back to show the entire range of data 

again.  

Stretching 

It can sometimes be very useful to identify a pass by exaggerating the data to the 

upper and lower limits of the graph. Within the context of the Armadillo 

Analyzer, this is called Stretching. 

As an example, see Figure 31, below. This data represents the magnetic signature 

from a tool going by. At first glance, you might assume there was no data here to 

make a valid pass selection… the magnetic signature appears flat. 



Armadillo 

 

 http://www.armadillotracks.com Page 30 

 

Figure 31 - Unstretched Magnetic Data 

When the magnetic graph is Stretched, however, we see an exaggerated signature. 

This allows for a pass time selection that you can have a much greater confidence 

in. 

 

Figure 32 - Stretched Magnetic Data 

In some cases this signal can be very weak due to the depth of cover at the site the 

AGM was placed. This stretching capability is one of the most useful tools in the 

Armadillo Analyzer for verifying a pass and selecting a pass time. 

Cropping 

If you have too much data within your pass, it can be difficult to locate the 

specific point you need to select without zooming in. Although zooming is 

effective, it is an unnecessary step once you’ve identified the “important” data. If 

you’d like to remove the extraneous data, you can crop your pass down to the 

zoomed-in view. This option will not be available if you are not zoomed in. 

 

Figure 33 – Crop Data To Shown 

You can right-click on your graph and select Crop Data To Shown or select Edit 

> Crop Data To Shown from the Main Menu. 

 

Selecting Pass Times 

The primary purpose of the Analyzer is to confirm and adjust the recorded pig passage 

times which will be exported and correlated with an Inline Inspection (ILI) tool clock and 

odometer. 
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There are two ways to choose pass times for the Pass files: 

1. Right-Click Menu 

2. Mouse Left Click + Alt key 

In each case, you may choose to undo this action by using ctrl-Z or selecting Edit > Undo 

from the main menu. 

Tip: You can save an image of a graph that you are analyzing by right-clicking and 

selecting ‘Save As’. A snapshot of the graph as it looks will be saved, including all 

text, lines, and hover messages. 

Right-Click Menu 

If your mouse is over a position that you would like to set as the pass time, you 

can simply right-click and select the “Set Pass Time” option. The pass time will 

be set right where the mouse was when you initially right-clicked. 

 

Figure 34 - Set Pass Time 

Mouse Left Click + Alt Key 

The easiest and most natural way to set the pass time is to hold down the Alt key 

while left-clicking on the graph. It can sometimes help to zoom in to more 

accurately select a time, especially if the range of data downloaded is larger. 

Continue to hold both the Alt key and the left mouse button, and move the line to 

the most appropriate position for the pass time to be set. 

Data Resolution 

Sometimes you will be working with a very large data set, and your computer 

may be very slow. The Data Resolution slider was integrated into the Detailed 

Info pane to give you flexibility in how much data is to be shown on your graph at 

all times. The lower the data resolution, the less data points actually shown. All 

data in between these points are dropped in favor of speed. 

It is in your best interest to keep the Data Resolution as high as possible to give 

the best representation of the data recorded. 
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Listening to Recorded Geophone Data 

If audio data is present for a selected Pass file, you can listen to it using the Geophone 

Play  button on the Detailed Info pane, by right-clicking on the graph and selecting 

“Play”, or by clicking on Analysis > Audio > Play on the main menu. 

It is highly recommended that you listen to this recorded geophone data with 

headphones or at least with amplified speakers. The sound quality will be much 

better. 

Only the current data range shown on the graphs will play, so if you would like to listen 

to a section in the middle of the data, just zoom in on it and play the audio. 

The quality of sound produced is directly proportional to how busy your computer is. It is 

recommended you reduce the Data Quality slider down while listening as this will 

increase the quality of sound output. 

When the amplify option is selected, the sound will be made as loud as possible without 

clipping. When deselected, the sound will be the original as recorded by the AGM. 
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Exporting Data 

Once you’ve confirmed the pass times, you will need to export the data. 

Export Steps 

1. Select Analysis > Export Data… from the main menu. 

2. The first screen of the wizard will show you the list of Pass files that were filtered 

in the Pass File List of the Analysis pane. 

 

Figure 35 - Choose Passes to Export 

Any files that you have in the filter that do not have a selected pass time will 

appear highlighted to let you know there is no selected pass time. To confirm, 

hover your mouse over each file and view the tooltip for file information: 

3. You can either select each file you’d like individually (using the ctrl-click 

method) or by right-clicking and choosing Select All. Once you have chosen the 

passes that you wish to export, click . 

4. Choose an export template. There are built-in templates that you can use, or you 

can create your own (see Figure 36 – Choose Export Template, below). 

 

Figure 36 – Choose Export Template 

5. If you would like to change the fields being exported, or the order of those fields, 

you can do so by highlighting the fields in either list and using the arrow buttons 

to move them. Once you are done, click . 

6. Choose the file to export the data to: 
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Figure 37 – Choose Export File 

If the file already exists, when you click , you will be asked if you would 

like to append the data. If you choose no, you will need to choose a new file. 

If the file selected does not exist, a new file will be created. 

You can click on the  button to open a new windows explorer to the 

location where the export file will be created. 

7. The next screen will show the progress of the data export. 

 

Figure 38 - Export Completed Successfully 

8. You may click the  button to open a Windows Explorer window at the 

location of your export file. This is convenient to verify the export. 

 

Export Templates 

If you find that you are consistently exporting data to a set format, or you have multiple 

supported formats, you can create an Export Template to make your exporting task 

simpler. 

An Export Template is simply a list of defined exportable fields from the Analyzer, 

organized in a manner you specify, and separated by the delimiter character or string that 

you specify. 

To create or manage your list of Export Templates, you can click on Manage Templates 

during the export flow (see Figure 36 – Choose Export Template), or you can click on 

File > Manage Export Templates. 
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Figure 39 - Manage Export Templates 

Using the Manage Templates window, you can create new templates, or delete old 

templates.  

 

You cannot edit a template once it is made and saved. If you 

need to do this, select the template you’d like to change, click 

, and edit the fields. 

 

When you create a new template you can choose the format of all dates and times that 

will be exported. Using the Date Format and Time Format drop-down boxes. 

 

Click on the  button to apply your current changes without closing the window, or 

on  to apply the changes and close the window. 

 

Export Template Fields 

The Armadillo Analyzer supports many fields for export. Most are self-explanatory, but 

the following fields need some clarification: 

Record Number When the pass data is exported, this number will start at 1 and increment by one 

for each pass. 

Pass Time UTC  This represents the pass time as a full date/time timestamp, including the 

milliseconds, using the UTC time. 

Pass Time Date UTC  This represents the pass time as a date only, using the UTC time. 

Pass Time Time UTC  This represents the pass time as a time only, using the UTC time. The 

milliseconds are not included. 

Pass Time MS  This represents the pass time’s millisecond component only. 
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Zipping Up Data 

You may wish to gather the list of filtered passes into a single file for archiving or simply 

for distribution to interested parties. 

Zip Steps 

1. Select Analysis > Zip Filtered Passes… from the main menu. 

2. Choose the name and location of the zip file that will be generated. 

3. Click OK 

4. All filtered passes (in the File Selection list) will be added to the zip file you have 

specified. 

 

You may now store this .zip file, or send it to anybody to unzip and view with their 

Armadillo Analyzer software. 
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Program Options 

The general operation of the Armadillo Analyzer can be modified by selection File > 

Options… from the main menu. 

The Options window has three tabs: Settings, Directories, and Diagnostics. 

Settings 

The Settings tab has the following settings. 

 

Figure 40 - Options - Settings 

Show Pass Time Labels When a pass time is selected for a pass, a text box with the 

selected pass time will be flagged on that line if this option is 

checked. This option is checked by default. 

Show Points on Hover When this option is checked, a textbox will follow the mouse 

and show the current timestamp and relative value of the point 

“under” the mouse. This option is checked by default. 

Allow Data Cropping This setting allows the user to delete extraneous data around a 

zoom-in pass. This option is checked by default. 

Prompt Before Saving When this option is checked, the Analyzer will double-check 

with you before saving. This is to ensure you do not 

accidentally save changes which cannot then be undone. This 

option is checked by default. 

GPS vs. UTC Time This choice reflects the policy chosen at first-time run. Please 

see GPS vs. UTC Time, above, for more information 

regarding this setting. This option does not have a default – it 

is chosen when the application is first run. 

Replace Downloaded If you select an exact range of data to be downloaded again, 

Files the existing data file in your repository will be replaced with 

this new download if this option is checked. If this option is 

not checked, the new data will be downloaded with an 

incrementing number on the end of the filename. This option 

is not checked by default. 
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Directories 

The Directories tab has the following settings. 

 

Figure 41 - Options – Directories 

Main Storage Location All storage paths within the Armadillo Analyzer will be 

relative to this main storage location. This includes the 

following subdirectories: Themes, Templates, and Cached 

AGMs. 
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Firmware Updates 

From time to time, there may be updates for the firmware that controls the AGM’s 

operation. It is recommended that you check regularly to see if there is a new firmware 

file to upload to all the AGMs that you use regularly. 

Checking for New Firmware Files 

1. The current Firmware version is specified on the Armadillo website: 
http://www.armadillotracks.com/AGMInfo/AGMInfo.aspx 

2. Contact us using the link provided. This is to ensure that any firmware you install 

can be managed by us to ensure a smooth upgrade. 

 

Update Steps 

Once you have the firmware file, you can upgrade your AGMs. 

1. Select Manage AGMs > Update Firmware… from the Manage AGMs menu. 

2. Select the Armadillo AGMs that you wish to set up at this time. Please refer to the 

Connection to Armadillo section for the instructions on how to do this. 

3. Once you have chosen the boxes you wish to connect to, click . The next 

screen prompts you to select a firmware file. 

 

Figure 42 – Firmware File Selection 

Please browse to the location where you have downloaded the firmware file. 

Select it, and click .  

4. The final screen shows the progress of each AGM being upgraded. Each AGM 

will be upgraded in parallel, greatly speeding up the firmware updates.  
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Figure 43 – Firmware Update Progress 

Each AGM will show the current progress for uploading the firmware.  

If you’d like to view a detailed report, click on the  button. This will show 

a list of items for that particular AGM. You may right-click this list to save 

the messages – this is useful when investigating reporting problems (see the 

Technical Support section). 

5. Once each AGM’s firmware update has completed, the  button will appear. 

Click it and the update screen will close. 

6. You will need to power cycle the AGMs that were updated. 

If you are connected using Bluetooth®, each AGM will 

automatically reboot itself after the window is closed.  

7. On startup, the LED will be red while the update is applied. 
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Bootloader Updates 

From time to time, there may be updates for the bootloader, which controls the initial 

behaviour of the AGM startup.  

Checking for New Bootloader Files 

Bootloader files will very rarely need to be applied. You will be notified when you 

contact us about new firmware whether a new bootloader needs to be uploaded to your 

AGMs. 

 

Update Steps 

1. Select Manage AGMs > Update Bootloader… from the Manage AGMs menu. 

2. Select the Armadillo AGMs that you wish to set up at this time. Please refer to the 

Connection to Armadillo section for the instructions on how to do this. 

3. Once you have chosen the boxes you wish to connect to, click . The next 

screen prompts you to select a bootloader file. 

Please browse to the location where you have downloaded the bootloader file. 

Select it, and click .  

4. The final screen shows the progress of each AGM being upgraded. Each AGM 

will be upgraded in parallel, greatly speeding up the bootloader updates.  

Each AGM will show the current progress for uploading the bootloader.  

If you’d like to view a detailed report, click on the  button. This will show 

a list of items for that particular AGM. You may right-click this list to save 

the messages – this is useful when investigating reporting problems (see the 

Technical Support section). 

8. You will need to power cycle the AGMs that were updated. 

If you are connected using Bluetooth®, each AGM will 

automatically reboot itself after the window is closed.  

9. On startup, the LED will be red while the update is applied. 
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Other Features 

This section details other features of the Analyzer that were not discussed elsewhere in 

this document 

Viewing All Filtered Passes on Google Maps 

At any time, you can view all of the pass files using a Google map by selecting View > 

 View Filtered Passes in Google Maps from the View menu. This option will only be 

available if you have an internet connection. 

Your default web browser will launch and display each pass on a single map represented 

by an AGM Marker. Each marker may be clicked on for more details about that pass, as 

shown below. 

 

Figure 44 - View All Filtered Passes 

A randomly-generated Access Code will be provided that you can share with anybody. 

They may then navigate to http://www.armadillotracks.com/AnalyzedRuns/ and enter this 

Access Code to view the same information. 

 

Viewing Single Pass on Google Maps 

When a Pass is selected in the Pass List, the Detailed Information pane will show the 

GPS coordinates of the AGM location when the data was recorded:  

If you click on the info button next to the GPS coordinates, you will be presented with the 

GPS-related info for this viewed pass file. If you then click on the coordinates link, an 

internet browser will launch to Google maps with the GPS coordinate visible.  
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If no internet connectivity is available, this button will be disabled. 

 

Theming 

The Armadillo suite of desktop applications all support coloured themes. This feature is 

for personal taste as well as to adjust colors and contrast for bright situations or poor 

reading eyesight. 

To change the theme, select View > Change Theme > [Name of Theme]. The application 

will update immediately to the new defined look. 

You can also modify an existing theme or make your own. 

Managing Themes 

Select View > Change Theme > Manage & Select…The list of current themes will 

be shown. The Armadillo Analyzer will always support Earth, Air, Fire, Water, 

and a basic Windows Default theme. If these themes are not present in the 

Themes directory of the application they will always be created. 

You can select each theme within the list and the color scheme of the application 

will instantly change in the background. 

You can also change a specific color and the application will change to allow a 

preview. Try it by changing the BackColor property. 

If at any point you’d like to save your changes, you can click  and the 

changes will be saved without closing the window. If you have made a mistake, 

click Cancel and the window will close, reverting to the prior theme. 

It is recommended that you not modify existing themes. If you’d like 

to try something new, copy the theme and edit the copy.  

 

Your themes are stored in your “My Documents\Armadillo\Themes\” 

folder. You can share your theme files with others... just have them put the file in 

their Themes folder. 

Here are some sample screen shots from themes: 
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Troubleshooting 

I am having trouble connecting with Bluetooth®. When I select this option and hit 

Refresh, my device shows up but the following dialog appears: 

Unfortunately, this is a limitation of using unpaired Bluetooth® devices. Please try 

the following sequence of actions to try and get communication working. 

1) Ensure the built-in Bluetooth® on your computer is turned off. 

2) Unplug and replug your Bluetooth® dongle. 

3) Close the Armadillo Analyzer and restart it. 

4) Reboot your computer. 

5) Turn the AGM off and back on and try again. 

Alternately, if you are familiar with how to pair Bluetooth® devices, please do so and 

select USB/Paired Bluetooth to connect. This is usually much more reliable. 

 

When I select Bluetooth® to connect to the AGMs, I get a changing list of devices, 

even when I hit refresh. 

Please check to ensure you are using a Class 1 Bluetooth® device to connect to the 

Armadillo AGMs. Class 2 Bluetooth® devices do not consistently detect all the 

AGMs in its vicinity and is unpredictable.  

Even with Class 1, however, the Bluetooth® search function is not perfectly reliable. 

Sometimes it just will not detect all the devices. It is recommended you use a USB 

cable to connect to any device that doesn’t show up in the Bluetooth® detection. 

 

When I select USB / Paired Bluetooth® to connect to the AGMs, my connected AGM 

does not show up. 

There may be a number of causes for this. Please perform the following steps: 

1. Please ensure your AGM is on before plugging in the USB cable. Communication 

with the AGM will be unsuccessful if the AGM is off when plugged in. 

2. Try unplugging the AGM and plugging it back in again. 

3. Hit  to see if your AGM shows up this time. If not, try power cycling the 

AGM, plug it in again, and hit  one more time. 

4. If you do not know the COM Port that your AGM is connected to, open the 

Device Manager on your operating system: 

1) Right-click ‘My Computer’ and select ‘Manage’ 

2) Select ‘Device Manager’ 

3) Expand ‘Ports (COM & LPT)’ 

4) Your connected AGMs should show up here as ARMADILLO AGM with 

the COM port number after 
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5. Select ‘Choose Port’ and select that COM port to force the software to use that 

COM port. You may need to uncheck the ‘Only show AGMs’ checkbox to view 

the port for selection. 

If you are still not able to connect, try plugging the AGM into a different USB port on 

your computer. This will assign a different COM port number and may allow the 

connection. 

If you are running Windows XP or earlier, the Armadillo USB driver needs to 

be installed for each USB port on your computer that you would like to use. 

This can be downloaded from our website: 

http://www.armadillotracks.com/AGMInfo/AGMInfo.aspx 
 

If this is the first time you are connecting an Armadillo AGM on that computer, you 

will need to install the driver. Here are the steps to do so: 

1)      Open up the device manager (select “My Computer”, right click and select 

‘Manage…’. Then select ‘Device Manager’ in the list) 

2)      Turn an AGM on, and plug it into the computer’s USB port 

3)      You should see the Device list refresh, and a device will show up that says 

“AGM Lite”. It is normally under “Other Devices” with a small warning icon 

4)      Right-click on that node, and select ‘Update Driver’ 

5)      Select “Browse my computer for driver software”. Do not select ‘Search 

Automatically’… it will not work 

6)      Browse to your Analyzer installation folder.  

a.      This should be on 
C:\Program Files\PureHM Inc\Armadillo Analyzer\ 

b.      If you use 64-bit computer, it should be 
C:\Program Files (x86)\PureHM Inc\Armadillo 

Analyzer\ 

7)      Click Ok 

8)      The system will detect the driver and install it for these devices.  

 

When I select Bluetooth® there is a list of AGMs shown that are not present. Why are 

they there? 

Bluetooth searches can take a long time, so the Armadillo Analyzer automatically 

caches a list of AGMs that you’ve successfully connected to in the past. This greatly 

speeds up reconnections. 

If you do not want certain AGMs to reappear in this list, you can select them, right-

click and choose ‘Forget Selected AGMs’ 
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I’m familiar with how to pair a Bluetooth® device to my computer. Can I pair the 

AGM and use it that way? 

Yes, you can.  

Every Bluetooth stack has its own software and behavior for pairing a device which is 

why we do not explicitly support this, but the process of device pairing is generally 

like this: 

1) Search for Bluetooth Devices 

2) Select the AGM and select “Add” or “Pair” 

3) If prompted, enter the PIN code of “0000” 

4) Wait until pairing is completed and make a note of the assigned virtual COM Port 

(eg: COM49) 

5) Choose “USB / Paired Bluetooth” from the communication window and select 

that COM port 

 

Why do my selected pass times differ by around 15 seconds from what the Pig Trackers 

report? 

This is most likely because the incorrect Time Standard has been chosen for the 

application. Please confirm the time standard used by your organization (UTC or 

GPS) and update the settings for the application in the Options dialog. If you are 

unable to find this out, chances are UTC is the correct option. 

Please update your software by visiting our website: www.armadillotracks.com 

 

The data of one channel is obscuring the data from another channel – especially for 

the 22 Hz. How do I see the data behind it? 

All you need to do is hover the mouse over the button of the data channel you would 

like to see. It will be highlighted and brought to the front of the graph. 

Optionally, you can turn each channel on or off by clicking on the corresponding 

button on the graph. 

 

 

 

 

 

 

 

 

 



Armadillo 

 

 http://www.armadillotracks.com Page 48 

I’ve tried to synchronize the time on my computer using the time on the AGM, but it’s 

not working. The time on my computer stays the same. 

Chances are that this is a permissions issue. You must have the proper user 

permissions on your system to adjust your system time. This is most commonly a 

problem on Windows 7, but there is a work-around. 

To launch Analyzer, hold shift and right-click. There should be an option in the menu 

that says “Run as administrator”. Select that option. 

Optionally, you can manually edit your shortcut on your desktop by right-clicking it 

and selecting ‘Properties’. Select ‘Advanced Properties’ and check the box that says 

‘Run as administrator’. This will ensure that each time the Analyzer is run, it will be 

with full administrator privileges, but you will be prompted by Windows to confirm 

this every time you launch. 
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Technical Support 

Support is available for this application through the following methods: 

 

 Email: support@armadillotracks.com 

 Telephone: 1-866-434-7872 

 Internet: http://www.armadillotracks.com 

 

Please ensure you have the following information available when you call: 

1. Your Name 

2. Company Name 

3. The Software Version Number (In the Help > About  menu) 

 

Log Files 

The Armadillo Analyzer saves detailed log files in the following location:  

My Documents\HM\Analyzer\LOGS\ 

There is a new log file for each day of use. Please locate the appropriate file and prepare 

to send them to our technical support personnel. 


